Linux OpenGL error

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Linux OpenGL error

runiter
I have a user who reported the exception below:

com.jogamp.opengl.GLException: J3D-Renderer-1: createImpl ARB n/a but required, profile > GL2 requested (OpenGL >= 3.1). Requested: GLProfile[GL3bc/GL3bc.sw], current: 3.0 (Compat profile, compat[ES2], FBO, software) - 3.0 Mesa 18.0.0-rc5
        at jogamp.opengl.x11.glx.X11GLXContext.createImpl(X11GLXContext.java:440)
        at jogamp.opengl.GLContextImpl.makeCurrentWithinLock(GLContextImpl.java:765)
        at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:648)
        at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:586)
        at org.jogamp.java3d.JoglPipeline.createNewContext(JoglPipeline.java:6415)
        at org.jogamp.java3d.Canvas3D.createNewContext(Canvas3D.java:4602)
        at org.jogamp.java3d.Canvas3D.createNewContext(Canvas3D.java:2376)
        at org.jogamp.java3d.Renderer.doWork(Renderer.java:881)
        at org.jogamp.java3d.J3dThread.run(J3dThread.java:271)


He's running the Java3D application on Linux Mint 19 with Java 1.8.0_171 64bit.

The output of glxinfo | grep OpenGL is:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.0.0-rc5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:


Any help is appreciated.
Saeid Nourian, Ph.D. Eng. | Graphing Calculator 3D
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
Hello

It comes from the JOGL bug 1357. I have a working fix, I just have to drive it a bit smarter.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

runiter
Are you sure this problem is same as bug 1357?

Bug 1357 seems to have a slightly different exception:

java.lang.InternalError: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped

But this user gets this exception:

com.jogamp.opengl.GLException: J3D-Renderer-1: createImpl ARB n/a but required, profile > GL2 requested (OpenGL >= 3.1). Requested: GLProfile[GL3bc/GL3bc.sw], current: 3.0 (Compat profile, compat[ES2], FBO, software) - 3.0 Mesa 18.0.0-rc5
Saeid Nourian, Ph.D. Eng. | Graphing Calculator 3D
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
Yes but you can still try to work around this bug by disabling OpenGL core and/or OpenGL ES.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

runiter
I see, thanks. I will wait for release then.
Saeid Nourian, Ph.D. Eng. | Graphing Calculator 3D
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
Have you tried the version of JOGL I use in TUER? It contains a first quick fix.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
In reply to this post by runiter
Actually, you were right, this isn't caused by the bug 1357 as "Mesa" is still in the OpenGL renderer string. I fear that it might be a bug of Mesa.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

runiter
Interesting. What do you think this user should do next? Report this problem in Mesa forum?
Saeid Nourian, Ph.D. Eng. | Graphing Calculator 3D
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
He should use a more recent version of Mesa first, the version 18.3.1 is currently the latest one. He can't report a bug against an "old" version. He should switch to Linux Mint 19.1 first.

P.S: Linux Mint 19.1 uses Mesa 18.3.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

philjord
Julien,
I have a question just for my enlightenment; it's currently selected the software profile, so ARB or not it'll never work with Java3D.
Are you thinking that the machine will support hardware 3.0 profile but it's simply not selecting that when asked for via getMaxFixedFunc(true)?
Thanks,
Phil.
Reply | Threaded
Open this post in threaded view
|

Re: Linux OpenGL error

gouessej
Administrator
Yes it's a "software" profile but it supports OpenGL 3 anyway. The situation isn't the same as under Windows as Mesa is a lot more capable than Microsoft GDI Renderer.
Julien Gouesse | Personal blog | Website