Unable to find toolchain

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Unable to find toolchain

Joel
This post was updated on .
I'm trying to run the command:
cmake .. -DCMAKE_TOOLCHAIN_FILE=../cmake/toolchain.android.cmake -DANDROID_TOOLCHAIN_VERSION=4.6 -DANDROID_API_LEVEL=9

I commented out this line (I'm on Yosemite):
# set(APPLE false)
added 4.6 as a version (4.6.0 was listed, but not just 4.6)

but I get
  Your compiler does not seem to have C99 inline semantics!

The code indicates gcc version 4.3+ should be fine, but I'm on 4.9!
Commenting that out...

gets to make:
In file included from /Users/joel/dev_3rd/openal-soft/OpenAL32/alAuxEffectSlot.c:29:0:
/Users/joel/dev_3rd/openal-soft/OpenAL32/Include/alAuxEffectSlot.h:25:93: error: expected ';', ',' or ')' before 'samplesIn'

Curious if I made a bad choice on gcc, or any general advice as to what to do.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Unable to find toolchain

Joel
Turns out I just had to be real careful how to invoke, that the toolchain picks up an appropriate gcc:
cmake .. -DCMAKE_TOOLCHAIN_FILE=../cmake/toolchain.android.cmake -DANDROID_TOOLCHAIN_VERSION=4.6 -DANDROID_API_LEVEL=9

this worked for me.
Loading...