Quantcast

With Apple Java for OS X (Java SE 1.6.0_37) installed I got this exception in java3d:

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

With Apple Java for OS X (Java SE 1.6.0_37) installed I got this exception in java3d:

aass359
3D [dev] 1.6.0-pre12-daily-experimental daily

Exception in thread "main" java.lang.NoSuchMethodError: jogamp.opengl.Debug.addTrustedPrefix(Ljava/lang/String;)V
        at jogamp.opengl.Debug.access$000(Debug.java:38)
        at jogamp.opengl.Debug$1.run(Debug.java:47)
        at java.security.AccessController.doPrivileged(Native Method)
        at jogamp.opengl.Debug.<clinit>(Debug.java:44)
        at jogamp.opengl.ThreadingImpl.<clinit>(ThreadingImpl.java:53)
        at com.jogamp.opengl.Threading.disableSingleThreading(Threading.java:164)
        at javax.media.j3d.JoglPipeline.initialize(JoglPipeline.java:130)
        at javax.media.j3d.Pipeline.createPipeline(Pipeline.java:92)
        at javax.media.j3d.MasterControl.loadLibraries(MasterControl.java:837)
        at javax.media.j3d.VirtualUniverse.<clinit>(VirtualUniverse.java:274)
        at demo3d.Demo3d.<init>(Demo3d.java:27)
        at demo3d.Demo3d.main(Demo3d.java:41)
Java Result: 1
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: With Apple Java for OS X (Java SE 1.6.0_37) installed I got this exception in java3d:

philjord
Aass359,
Im not at my computer right now but it looks like the version of gluegen that java3D is using is not correct, possibly you've got an older version. It needs to be 2.3.2.

I'll add some links on how to check this and how to install the latest version later on, unless someone else beats me to it.

Thanks,
Phil
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: With Apple Java for OS X (Java SE 1.6.0_37) installed I got this exception in java3d:

philjord
The instructions for updating Jogl (to 2.3.2) for Java3D are located here:
https://jogamp.org/wiki/index.php/Java3D_FAQ

Here are the instructions for ensuring Jogl and Gluegen are both 2.3.2
https://jogamp.org/wiki/index.php/Jogamp_Versioning_and_Releases#Runtime_Version_Check


Please update and re-run the program, then post back your result (hopefully success...)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: With Apple Java for OS X (Java SE 1.6.0_37) installed I got this exception in java3d:

gouessej
Administrator
In reply to this post by aass359
Hi

Apple Java is NOT supported by Java3D 1.6.0 and later, this is explained in the Java3D 1.6/1.7 user's guide. Please use OpenJDK or Oracle Java instead of Apple Java. I remind you that Apple Java has been deprecated for several years. Moreover, you might have to switch to Java3D 1.7 to avoid some conflicts with an obsolete version of Java3D (1.3?) installed by Apple on your operating system with some obsolete versions of JOGL (1.1?) and GlueGen.

Maybe Phil is right, you should use JOGL 2.3.2 with Java3D 1.6 but it might not be enough.
Loading...