Reply – Re: How to run Java 3D 1.6 under old Intel processors with integrated graphics?
Your Name
Subject
Message
or Cancel
In Reply To
Re: How to run Java 3D 1.6 under old Intel processors with integrated graphics?
— by gouessej gouessej
Why using the reflection whereas JOGL 2 is already a dependency as you use Java3D 1.6? If you drop Java3D 1.5, adding JOGL 2 as a compile time dependency won't be a problem.

Why do you use a link to an obsolete unmaintained version of Java3D? The correct link is here:
http://jogamp.org/deployment/java3d/1.6.0-final/javadoc/javax/media/j3d/RenderingErrorListener.html

I think that it just complains about the version of OpenGL being too low.

The Minecraft maintainers don't really take care of this issue, they don't mind and it can't be fixed by Oracle, it's none of their concern, Intel is to blame. JavaFX 3D doesn't use the OpenGL pipeline by default under Windows.

If I were you, I would run the necessary command only when it's needed.

Maybe this helps:
https://jogamp.org/bugzilla/show_bug.cgi?id=1278
Julien Gouesse | Personal blog | Website