Reply – Re: Crash on Macos using Java 9
Your Name
Subject
Message
or Cancel
In Reply To
Re: Crash on Macos using Java 9
— by ncollier ncollier
I ran the JOGLQuadExample under Java 10.

iMac:Downloads nick$ java --version
java 10.0.1 2018-04-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.1+10)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.1+10, mixed mode)


If I quit it, using command-Q (Apple's standard app quit) then I don't get any error. If I close the window explicitly then I get the JRE crash

I've put the log for that here:

https://www.dropbox.com/s/p2g39jvuhf235eu/hs_err_pid10822.log?dl=0'

I tried 'java -jar jogamp-fat-test.jar' again, I don't get a JRE crash in either case. However, if I try to close the window, it goes blank and hangs and I have to force quit. If I quit with  command-Q, I get:

Exception in thread "main-AWTAnimator#00" com.jogamp.opengl.util.AnimatorBase$UncaughtAnimatorException: com.jogamp.opengl.GLException: Caught ThreadDeath: null on thread main-AWTAnimator#00
        at com.jogamp.opengl.util.AWTAnimatorImpl.display(AWTAnimatorImpl.java:92)
        at com.jogamp.opengl.util.AnimatorBase.display(AnimatorBase.java:452)
        at com.jogamp.opengl.util.Animator$MainLoop.run(Animator.java:204)
        at java.base/java.lang.Thread.run(Thread.java:844)
Caused by: com.jogamp.opengl.GLException: Caught ThreadDeath: null on thread main-AWTAnimator#00
        at com.jogamp.opengl.GLException.newGLException(GLException.java:76)
        at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:1327)
        at jogamp.opengl.GLDrawableHelper.invokeGL(GLDrawableHelper.java:1147)
        at com.jogamp.newt.opengl.GLWindow.display(GLWindow.java:759)
        at com.jogamp.opengl.util.AWTAnimatorImpl.display(AWTAnimatorImpl.java:81)
        ... 3 more
Caused by: java.lang.ThreadDeath
        at java.base/java.lang.Thread.stop(Thread.java:949)
        at com.jogamp.newt.opengl.GLWindow$GLLifecycleHook$1.run(GLWindow.java:724)
        at java.base/java.security.AccessController.doPrivileged(Native Method)
        at com.jogamp.newt.opengl.GLWindow$GLLifecycleHook.shutdownRenderingAction(GLWindow.java:719)
        at jogamp.newt.WindowImpl.shutdown(WindowImpl.java:635)
        at jogamp.newt.WindowImpl.shutdownAll(WindowImpl.java:123)
        at jogamp.newt.DisplayImpl$1.run(DisplayImpl.java:74)
        at com.jogamp.nativewindow.NativeWindowFactory.shutdown(NativeWindowFactory.java:272)
        at com.jogamp.nativewindow.NativeWindowFactory$2$1.run(NativeWindowFactory.java:190)
        ... 1 more


Hope this helps.

If I could get the details of the bug report, I could probably look into this further. Thanks.

Nick