Reply – Re: com.jogamp.opengl.swt.GLCanvas does not work with Eclipse 4.8 under Linux
Your Name
Subject
Message
or Cancel
In Reply To
Re: com.jogamp.opengl.swt.GLCanvas does not work with Eclipse 4.8 under Linux
— by gouessej gouessej
Hello

The class still exists:
https://git.eclipse.org/c/platform/eclipse.platform.swt.git/tree/bundles/org.eclipse.swt/Eclipse%20SWT%20PI/gtk/org/eclipse/swt/internal/gtk/OS.java

We should use the GTK class in this case:
https://git.eclipse.org/c/platform/eclipse.platform.swt.git/tree/bundles/org.eclipse.swt/Eclipse%20SWT%20PI/gtk/org/eclipse/swt/internal/gtk/OS.java#n96

We should catch the NoSuchFieldException and call GTK.gtk_major_version(), gtk_minor_version() and gtk_micro_version().

If I provide a patch, will you have any time to give it a try?
Julien Gouesse | Personal blog | Website