New User Installation Help - Vista 64 on AMD 64

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view

New User Installation Help - Vista 64 on AMD 64

Hi. I'm a new user/student trying to get started with JOGL.

I downloaded [], the most recent JOGL file that I saw, and unzipped the contents into [C:\Program Files\Java\jogl-2.0].

I then setup my environment variables as follows. For my PATH user variable, I have [other_PATH_stuff;C:\Program Files\Java\jogl-2.0\lib;]. For my CLASSPATH system variable, I have [other_CLASSPATH_stuff;C:\Program Files\Java\jogl-2.0\lib\jogl.all.jar;C:\Program Files\Java\jogl-2.0\lib\nativewindow.all.jar;C:\Program Files\Java\jogl-2.0\lib\gluegen-rt.jar;C:\Program Files\Java\jogl-2.0\lib\newt.all.jar;].

I then try to compile a JOGL test window, taken from Justin's  JOGL tutorial 2 page. For convenience, the following is the code I'm trying to compile and run:

import java.awt.Frame;
import java.awt.event.WindowAdapter;
import java.awt.event.WindowEvent;

public class SimpleScene {
    public static void main(String[] args) {
        GLProfile glp = GLProfile.getDefault();
        GLCapabilities caps = new GLCapabilities(glp);
        GLCanvas canvas = new GLCanvas(caps);

        Frame frame = new Frame("AWT Window Test");
        frame.setSize(300, 300);
        // by default, an AWT Frame doesn't do anything when you click
        // the close button; this bit of code will terminate the program when
        // the window is asked to close
        frame.addWindowListener(new WindowAdapter() {
            public void windowClosing(WindowEvent e) {

From cmd.exe, here is my attempt at compiling the above code:

SomePath\HelloJOGL>javac cannot find symbol
symbol  : constructor GLCapabilities(
location: class
        GLCapabilities caps = new GLCapabilities(glp);
1 error


It looks like Java is finding some stuff ([GLProfile]), but not others ([GLCapabilities]). I'm also not sure what functionality is removed by the various profiles. Could this be affecting the usage of [GLCapabilities]? Any help is appreciated.
Reply | Threaded
Open this post in threaded view

Re: New User Installation Help - Vista 64 on AMD 64

Demoscene Passivist
Your code is perfectly fine (at least compiles in my eclipse environment - using 32bit JOGL2). Classpath also looks ok but the javac compiler error "cannot find symbol" is usually a classpath problem.

Maybe the is broken again ? There was an issue with amd64 build a couple of days ago. Take a look here:

So try this build as suggested my Michael: 
Reply | Threaded
Open this post in threaded view

Re: New User Installation Help - Vista 64 on AMD 64

I'm up and running now, but it was strange getting things to work. Basically, I deleted the contents of [C:\Program Files\Java\jogl-2.0], copied and pasted a jogl release into that folder, and then tried to compile my program. This is the order in which I tried various packages, starting with my first post.

[jogl-2.0-pre-20100928-windows-amd64]  --  failed
[jogl-2.0-pre-20100915-windows-amd64]  --  failed
[jogl-2.0-pre-20100727-windows-amd64]  --  passed (tried to get some kind of reference point by using the earliest package I saw)
[jogl-2.0-pre-20100927-windows-amd64]  --  passed
[jogl-2.0-pre-20100928-windows-amd64]  --  passed
[jogl-2.0-pre-20100915-windows-amd64]  --  passed

I am now using [jogl-2.0-pre-20100928-windows-amd64] and I can compile and execute without problems. I also just restarted my machine and things are still working.