shader not work in X server

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

shader not work in X server

yaqiang
Volume redering was suported in MeteoInfo with shaders (http://www.meteothink.org/news/meteoinfo_3.1.0.html, code: https://github.com/meteoinfo/MeteoInfo/tree/master/meteoinfo-chart/src/main/resources/shaders/volume). All other 3d plot functions were implemented using traditional openg way without shader. I connect Linux server by SSH from a windows desktop using Mobaxterm software (https://mobaxterm.mobatek.net/) which has a X server with opengl supporting. So I can run MeteoInfo in it and dispaly 3d figure normally when the plot function not using shader. But 3d figure created from volumeplot function (with shader) can not be dispaly and the program has no response.

Anyone has experience on this problem? Thanks!
Reply | Threaded
Open this post in threaded view
|

Re: shader not work in X server

gouessej
Administrator
Hello

It's probably a limitation of MobaXTerm's X server which supports an old version of OpenGL.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: shader not work in X server

yaqiang
Thanks for your information!
Reply | Threaded
Open this post in threaded view
|

Re: shader not work in X server

gouessej
Administrator
Your feedback would be welcome. Let us know whether you have found a solution.
Julien Gouesse | Personal blog | Website
Reply | Threaded
Open this post in threaded view
|

Re: shader not work in X server

yaqiang
Still not find solution of it.