Reply – Re: Change: JogAmp Module's Java Language Version Constraints
Your Name
Subject
Message
or Cancel
In Reply To
Re: Change: JogAmp Module's Java Language Version Constraints
— by Michael Bien Michael Bien
  no complains - great :)

JogAmp moved yesterday to Java 5 language level. Latest Jenkins builds
already went through cleanly.

http://jogamp.org/deployment/autobuilds/master/

we are now all happy to get rid of some internal backwards compatibility
codepaths.

best regards,
michael

On 02/08/2011 03:04 AM, Sven Gothel [via jogamp] wrote:

> Dear All,
>
> after a long beating I had to take for keeping up with the
> J2ME compatibility and hence the Java source level 1.3 constraints,
> I give in bumping up the upper bar to 1.5 :)
>
> Now we are 3 core developers (Michael, Rami and Sven) plus many others
> who expressed their desire to 'enhance' this situation,
> ie using new language features and styles etc.
>
> Since JamVM, Dalvik and other mobile JVMs support the 1.5 language level
> and we haven't seen anymore J2ME/CVM/CDC JVM running on multimedia devices
> there is little reasoning continue it's support.
>
> We have decided the following for all JogAmp modules, each should:
>
> - support Java source level 1.5
>
> - support JVM 1.5 (when using JVMs, besides others, ie dalvik)
>
> - don't exceed dalvik's library features (level ??)
>    http://developer.android.com/reference/packages.html
>
> - implementation may use 1.5 features
>
> - new API stuff may use 1.5 features
>
> - old API stuff may change to 1.5 features after release 2.0
>
> Cheers, Sven
>

--
http://michael-bien.com/