Mac Appstore no longer accepts 32bit/universal JOGL

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Mac Appstore no longer accepts 32bit/universal JOGL

runiter
Today when I tried submitting my Java3D desktop app to Mac Appstore I got an error complaining that it contains 32bit/universal libraries. Evidently Apple only accepts 64bit libraries now. Is there a 64bit version of JOGL mac library available somewhere?
Saeid Nourian, Ph.D. Eng. | Graphing Calculator 3D
Reply | Threaded
Open this post in threaded view
|

Re: Mac Appstore no longer accepts 32bit/universal JOGL

gouessej
Administrator
Hello

The Mac Appstore accepts only 64-bit libraries since June 2018. No there is no such libraries yet but I assume that the Objective-C code already uses LP64, it should help to compile JOGL native 64-bit libraries without having to modify the source code.

The JogAmp server was updated several months ago but some things are still broken, including the bug tracker. Somebody suggested to use Gitlab CI in the meantime to build JOGL until the JogAmp server is able to get the job done anew but I have seen nothing ready, maybe I've missed something.
Julien Gouesse | Personal blog | Website